Vulnerability in OpenSSL may cause remote servers to malfunction

image


OpenSSL developers have released a fix for a dangerous vulnerability in their software library. Its operation allowed attackers to cause a denial of service (DoS) state when analyzing certificates.

The vulnerability (CVE-2022-0778) was rated 7.5 points on the CVSS scale and is associated with the syntactic analysis of a distorted certificate with invalid explicit parameters of an elliptic curve, which leads to the so-called “infinite loop”. The problem lies in a function called BN_mod_sqrt(), which is used to calculate the modular square root.

“Since the certificate parsing takes place before the certificate signature is verified, any process that analyzes an externally provided certificate can be subjected to a denial of service attack. An infinite loop can also be achieved by analyzing the generated private keys, since they may contain explicit elliptic curve parameters,” the OpenSSL bulletin says.

Currently, there is no evidence that the vulnerability was used in real attacks. The problem affects OpenSSL versions 1.0.2, 1.1.1 and 3.0 and has been fixed in OpenSSL versions 1.0.2zd (for premium support customers), 1.1.1n and 3.0.2. OpenSSL version 1.1.0 is also vulnerable, but will not receive fixes due to the end of the support period.

Start a discussion …